RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 7 of 7 Posts

·
El Controlador
Joined
·
1,074 Posts
Discussion Starter #1
Hey guys. Ive been gone from here for over a decade! I wonder if some of you old dudes are still around.

Anyway, I'm still alive, and I'm still riding my 2005 Z1000. I just recoated my exhaust headers and found myself a little nostalgic for my time here. I thought I'd stop by and say hello to old friends and introduce myself to new ones.

FWIW, here is one of my favorite pics of the old girl.

Cheers,
KX

122331
 

·
Registered
Joined
·
5,199 Posts
Welcome back. You may find the place more of a ghost town now...
 

·
El Controlador
Joined
·
1,074 Posts
Discussion Starter #3
Welcome back. You may find the place more of a ghost town now...
Sure seems that way! This joint was hoppin back in the day. Oh well. Nothing lasts forever. ?
 

·
Registered
Joined
·
5 Posts
Hey y’all, I’m new to this group, and a new rider. I just purchased a used 03 z1000 and I just installed a power commander 5. Bike came with a full akro leo Vince titanium exhaust, steering dampener, and led’s. I have noticed a small oil leak on the left hand side of the bike (gasket cover). Any advice would be greatly appreciated as to how to maintain this bike, and what to watch out for. It has 33k miles on it.
 

·
Registered
Joined
·
425 Posts
Good to see some of the OGs still here. I posted my bike for sale yesterday then got all depressed. Don't think I can let it go. I feel like this forum was way more active before photobucket made a lot of the info unavailable. Now you go to find info and its all blocked.

New guy. Find the manual. The service manual is around here somewhere for download as a PDF. Go to work and print it off. These bikes don't need much other than fuel and oil. Someone has a good write up on valve shim adjustments too. Keep good coolant like engine ice in it and change it one a year or so. These can run a little hot in traffic byt I have never had temps over say 218. I think some people get up to 230 down south.
 

·
Registered
Joined
·
1 Posts
Hey I see some of you guys have probably had your z1000 a lot longer than I have. Anyway I have an 03 and I can’t figure out what is wrong when I’m riding her I can only get to 6-7k rpm then it lurches/sputters hard and doesn’t have the power to climb any higher. It’s fine in low rpm, any advice? Btw I live 400 miles from the closest dealership.
 
1 - 7 of 7 Posts
Top