RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
My z750s recently started acting a bit strange. It will start up just fine but when it first starts and is idling the idle is rough. it goes between 500 rpm and 1000 rpm. If i get on and go, it will feel just fine nice and strong but once i get to the end of my street like 200 years if i clutch in and come to a stop it almost always will stall out. After some riding and letting it warm up the revs look REALLY solid on 1000 rpms at idle most of the time but occationally it will still stall if i am braking hard to a complete stop.

Its really annoying and this is my first fuel injected bike so i dont really know where to start. Any help would be greatly appreciated. If you need anymore details ill try my best to clue you in!!


Thanks
 

·
Registered
Joined
·
81 Posts
^ Has it been sitting?
Try bumping the idle up to 1050 RPM. Run some some fuel injector cleaner Techron or SeaFoam through it..
You may get lucky, easy fix.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
The bike was the previous owners daily driver but it sat for about 2 weeks maybe while i was getting the title and insurance done. Ive ridden it at least a couple times a week since then so I dont think that it sat around for too long.

I put some injector cleaner in and bumped the idle up just a bit so we will see how that goes! It looks good right now but the problem is a bit on and off so ill update if those two things didnt fix it. Thanks!
 

·
Banned
Joined
·
3,123 Posts
I put some injector cleaner in and bumped the idle up just a bit so we will see how that goes! It looks good right now but the problem is a bit on and off so ill update if those two things didnt fix it. Thanks!
Other routine maintenance might be in order now if you don't know what has been done.
Check/replace the air filter.
Clean the throttle bodies.
Replace the plugs.
Check the plug wires.
 

·
Registered
Joined
·
1 Posts
Hi guys,
I have the same issue with my z750s 2006, so same model/year...
When the engine is cold and I rev the bike like 7k rpm and shut it quickly, it will stall...
It did happen once on the road, I was doing 110km/h and I pull the clutch and rev the bike very high than shut the gaz quick and the bike stalled...

Anyway, in normal running condition, the bike is great and don't have any fail.
 

·
Registered
Joined
·
1 Posts
Same issue here however my bike had about 5 years in storage with tank removed. I install new fuel pump still stalls when I dump throttle
 
1 - 7 of 7 Posts
Top