RiderForums.com - Kawasaki Motorcycle Forum banner

21 - 29 of 29 Posts

·
Registered
Joined
·
347 Posts
McRider, you just save me again!! All the part numbers in one place!! Mine just started leaking, well I just found out it's leaking that is. Judging by the amount of oil and road grime I found on the lower fairings, it appears to have been leaking for a while. Looks like it's time to order some parts.

Oh and by the way, the custom seat you sold me last summer has been a life saver!!
 

·
Registered
Joined
·
1 Posts
I have a 2013 Ninja 650 with less than 1000 mi on it. There is a small amount of oil leaking from my water pump weep hole. After pulling things apart, I can see that the water pump impeller shaft is slightly pitted and rusty where the oil seal makes contact. This probably chewed the oil seal and is causing my leak. Is there any way to fix this other than opening the engine and replacing the shaft? I've read some people have tried sanding the rust down with emery cloth, starting with 320 grit and working up to 600 grit. Seems like it would still leak if there is pitting on the shaft. One person mention filling the pits with epoxy, then sanding down. Any advice would be greatly appreciated.
Apologies for the thread revive, I seem to be suffering from this issue, oil seeping out the weep hole. I am yet to open up the housing to see and replace seals I just want to clarify with owners who opened up and found rust and pitting on the shaft. What was the plan of action? Did you leave it, sand it or use some sort of metal polish to clean the shaft? Basically, what did you do before sliding on the new mechanical seal?

Mine is a 2016 registered ER6n with 12000km's on the clock.
 

·
Registered
Joined
·
11 Posts
Is a slight amount of oil from the weep hole normal? I don't have any buildup or spots on the floor. However if I touch the hole, there is a oily residue on my finger. I read somewhere that slight moisture/oil is normal for a water pump in general. I don't know. Bikes brand new but dealer is far. I only touched it after stumbling on these threads.
 

·
Registered
Joined
·
354 Posts
I dare say a small amount would be normal I mean why else would Kawasaki put a weep hole if it’s not meant to weep? Mine has residue but seems to be dry/greasy rather than oily. Not sure if that helps? I might look through the service manual and see if it’s mentioned anywhere
 

·
Registered
Joined
·
11 Posts
I dare say a small amount would be normal I mean why else would Kawasaki put a weep hole if it’s not meant to weep? Mine has residue but seems to be dry/greasy rather than oily. Not sure if that helps? I might look through the service manual and see if it’s mentioned anywhere
Ok cool, thanks. Mine isn't even enough to soak up a qtip after a long ride. It just has a greasy feel near that weep hole. Just wanted to jump on that if it was an issue. I will keep an eye on it. Apparently the weep hole is there to let one know if an oil seal or coolant seal is blown. But most of the threads or info I read had a good amount coming from that hole.
 

·
Registered
Joined
·
1 Posts
Hello, i'm facing the same problem.


i did 4 attemps to fix this problem (I hope it really fixed).
1st attempt:
Oil and Coolant leak on waterpump cover.
effort: Changing mechanical seal (49063, 92049).
When changing mechanical seal, in my local blog ( DIY: Change Seal Water Pump - ER6 ) said that we should put grease on 92049 seal. i put a lot of grease on it.
result: after 2 days, oil started to leak again.

2nd attempt:
Oil leak on waterpump cover.
effort: changing o-ring 92055B.
My assumption are since it leaks oil so this o-ring must be changed.
and also i tried to remove all grease (not all of it) that i put on my 1st attempt.
Result: no leaks for 2 weeks and then coolant started to leak.

3rd attempt:
Coolant leak on waterpump cover.
Effort:
Put gasket sealant on 92055 (since in my main dealer place, this o-ring are sold out). but it better if you can replace this oring
My assumption since coolant leaks this time, so i was checking on 92055. it is true that 92055 are leaking. so i put gasket sealant.
Result: No leaks for 1 month and then this time oil started to leak again.

4th Attempt (Today):
Oil leak on waterpump cover.
Effort:
remove all grease from 92049, clean all grease on 13227/A. and then i tried to clean the shaft to make sure there is no grease.
put gasket sealant again on 92055(main dealer still doesnt have any stock with this o-ring).
My assumption by this reply (Oil leak at water pump......which seal?) when oil leaking that means i need to replace 92049 and 92055B. but i just replaced it months ago with the new one. so i think i put it wrong because i put grease on my first attempt. so i clean all grease from 92049 and from all parts.

Result:
i'm testing my bike around 2 Kilometer, and there are no leaks anymore. i hope this really solved my problem.

Question:
1. is it wrong to put a grease(i put Lithium Grease on mine) on 92049 ??
because on this link he put so many grease on 92049.

he put grease like that.
could be this is the main issue?


Thank you
 
21 - 29 of 29 Posts
Top