RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So I went and bought a new speedometer for my 06 ninja 650r. When installing the speedometer I bumped wires together on accident and now it would start( no noise when the key is turn, no crank)... I check the fuses and it was two 10 amp fuse.. After replacing the fuse I hear it crank but no power when I first turn the key... I went back and replaced the 15 amp fuses and now I hear the power when turning the key but it wont crank..
Does this sound familiar to anyone?
Thanks
 

·
Registered
Joined
·
354 Posts
I can't offer much insight but in general reverse the things you did one by one until functionality returns.
Check all fuses and disconnect the gauge. Also you might be disturbing some wiring in there somewhere so be wary!

Good luck!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks.
So I check all fuse and my spark plugs and there good.. I even got it to start twice yesterday.I think it's the kill switch.. When my kickstand it down the kill switch on the handlebar doesn't work. When I put the kickstand up and flip the kill switch i hear the noise indicating it's on but the bike still wont start.
 

·
Registered
Joined
·
354 Posts
Thanks.
So I check all fuse and my spark plugs and there good.. I even got it to start twice yesterday.I think it's the kill switch.. When my kickstand it down the kill switch on the handlebar doesn't work. When I put the kickstand up and flip the kill switch i hear the noise indicating it's on but the bike still wont start.
I don’t understand. But if you’re having intermittent start issues then it could be clutch, kickstand or neutral switch that are an issue.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Could it be the kill switch because the fuel pump wont prime unless the killswitch is engaged before I turn the key.... I already checked fuses, and bypass the kickstand killswitch
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Also if I turn the bike on like normal ( turn the key then hit the kill switch) the fuel pump primes half way. What does that mean?
 

·
Registered
Joined
·
4 Posts
Can I piggyback in this thread? I went for a ride yesterday and all was good. Later when I tried to start the bike, the red battery light was flashing, as were all my added on gauges; gear indicator, temp and charge, also my tail light was flashing. There was a clicking sound from underneath the tank. The bike wouldn't kick over despite the battery having full charge. Any clues? 2009 ER6F.
 
1 - 10 of 10 Posts
Top