RiderForums.com - Kawasaki Motorcycle Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Can anyone help? I've got a ninja 650 2017 that won't start. I rode her for 100 miles yesterday stopped for a cup of coffee and she wouldn't start, not even tried to turn over. The lights (dash) are on but no one is home. The fuel pump engages but that's about it. I had a couple of biker mates that tried to bump start but that was a no go either. After a couple of minutes I pushed the starter button and away she went. Thinking it's recently had a service and knowing they don't start when a little low on oil I took her to the nearest friend's house, 4 miles away, turned her off and waited for her to cool (90 mins) oil was fine just below the full line, tried to start her and nothing. I've tried tge fuses, all are good, I've flicked the stop switch on and off several times, checked the starter plate and the side stand switch. Anyone have any ideas please?
 

·
Administrator
Joined
·
2,648 Posts
Welcome onboard. Check that your battery cable bolts are securely tightened on the battery.
 

·
Registered
Joined
·
44 Posts
Hope you solved problem since, if not. If bike was in good shape, stator or rectifier could be the problem...if battery good.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Had the bike transported back home to me so the electrician could look at it, got her off the van pushed the start button and she started. Looks like the alarm so had it taken off for now. Thanks for all the answers.
 
1 - 9 of 9 Posts
Top