RiderForums.com - Kawasaki Motorcycle Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So I recently bought a 06 z750s it's been about 2months ago don't know much about the bike other than it has a rebuilt title and runs good for the most part I ride it often but I'm having some issues with the rear end when going down the highway at 65 to 75mph after about 15min it feels like the brakes are on if i let off the throttle it slows way faster than normal and i have to give it more throttle than normal to maintain same speed also every once and awhile it feels like rear end is sliding side to side almost like a fishtail now i know it's not the brakes and I've put her up on the stand checking for any movement in rim or swingarm all right no play on top of the rear issue it also seems to run rich it has a yoshi slip on and when by it the fumes are horrible even after riding my clothes smell like fuel and it lags on throttle somewhat bt once it starts going and you pin it it flys i actually was on a straight strip and pinned her from about 10mph in 1st and when i hit second she stood straight up on me and hit 100mph in a blink of an eye so i know it can't be nothing serious wrong cause she will go just lacks that pep in throttle response and I'm having severe problems with finding parts any help would be greatly appreciated in desperate need of gas tank front fairing and headlight and said covers for radiator I have changed air filter to a k& n changing plugs and oil tomorrow also k&n oil filter just trying to get her back to great running condition she has 23,000 miles on her but still runs strong so I'm willing to put some more money in her cause I see and feel her beastly potential thanks in advance for your help
122581
 
1 - 1 of 1 Posts
Top