RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hey everybody

i have an 05 meanie cali model with original intake, ecu and hard krome pipes. My idle stays between 900-1000 rpm and very little cold start issues. Recently, i would come to a stop at a light on the freeway offramp, slowing down from about 80 mph, and my idle will vary from 300-900 and sometimes stall out. The second i put the bike in neutral, idle returns to normal. Vice versa, I put it back in first gear to roll off the idle goes crazy again until i hit the second stop light and she peers like feral kitten i bought to begin with.

My throttle grips does not stick, fast idle handle and idle adjuster work properly. if anybody has info on where to go next would be helpful. Mind you, I'm a little intimidated to remove the tank myself and the bike, even though used, has a three year parts warranty. for parts that do not wear normally, i.e. brake pads and rotors not covered.

thanks
vert
 

·
Registered
Joined
·
1,833 Posts
Welcome to the forum.

I'm not any sort of motorcycle mechanic, so take all this with a grain (or pound) of salt.

Mostly here I have seen responses to idle issues as an air/vacuum leak.

However, to me, it sounds like perhaps the clutch is not fully disengaging (only thing I can think of). So, first I would check the oil level (when was it last changed and what kind of oil are you using, specifically).

After that, I'm with you ...... I'm posting here to ask those with experience if they may have a better idea.

I'm sure someone with a lot more knowledge will be by soon with more questions for you and a pretty good idea of what is going on.

However, in many parts of the country, it's riding weather. So it may be awhile before you can get some advise in pinning this down.
 

·
Registered
Joined
·
330 Posts
If it was me I would run some seafoam through it to take out any change it is not getting fuel second I am thinking spark how old are those plugs? And third have you checked the air cleaner? maybe its not breathing well when you slow down I would want to check the filter and butterflies on the throttle body....
 

·
Registered
Joined
·
2,497 Posts
Sea Foam, 2oz/gallon of fuel. The chances are a dirt particle or fuel system residue is causing the issue. Start there, if it continues after you burn that tank off check vacuum lines and or marble trick plugs on intake mounting plate beneath air cleaner. Replace or clean the filter while your at it.
 

·
Registered
Joined
·
764 Posts
Good advice.

What confuses me and leads in another direction is the fact that in neutral it idles fine, but not while in first. If the clutch were not disengaging you would feel it trying to move forward.
 

·
Registered
Joined
·
1,066 Posts
hey everybody

i have an 05 meanie cali model with original intake, ecu and hard krome pipes. My idle stays between 900-1000 rpm and very little cold start issues. Recently, i would come to a stop at a light on the freeway offramp, slowing down from about 80 mph, and my idle will vary from 300-900 and sometimes stall out. The second i put the bike in neutral, idle returns to normal. Vice versa, I put it back in first gear to roll off the idle goes crazy again until i hit the second stop light and she peers like feral kitten i bought to begin with.

My throttle grips does not stick, fast idle handle and idle adjuster work properly. if anybody has info on where to go next would be helpful. Mind you, I'm a little intimidated to remove the tank myself and the bike, even though used, has a three year parts warranty. for parts that do not wear normally, i.e. brake pads and rotors not covered.

thanks
vert
Take everyone's advice before removing the tank. I know some folks do it themselves, but I have my wife hold it while I disconnect the fuel lines because it is too sketchy to hold it and remove the fuel lines.
+1 on remove the intake and clean the throttle bodies. I did that and sprayed seafoam into the throttle bodies while revving the engine (or it will stall). that cleaned stuff out pretty good along with a little scrubbing with a toothbrush. ** do not do this in the garage, it gets very smokey. It will also let you know if you have an exhaust leak anywhere (I did - crush gaskets at the headers).
 
1 - 7 of 7 Posts
Top