RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I searched the threads but couldn't find what I was looking for so hoping to find some help here. About two years ago I installed a Hard Krome sidewinder exhaust and finally decided to get a used power commander 3 and do the modified version of Caddman kit mod which is adding air cleaner to right side with left side stock. I completely removed the ISC valves and capped off the tubes. My meanie looks to be a California model because it has an EVAP cannister in left side cover. First time out with the new mods was unbelievable...ran like a raped ape with a power band that wasn't there before. I was grinning from ear to ear, until the next day when I had more time to put it through the paces. It developed a strange misfire like one or two of the spark plug wires came off but it would do that intermittently. It would run fine one second and then the other run like crap. Checked plugs, front two were black from the misfire. I decided to unplug the PC3 completely and the problem went away. However, I developed a new problem...throttle sticking. Funny thing is, it doesn't seem to be mechanical because the twist throttle will return, along with the cables and of course the butterflies of the valve body, yet the rpm's stay way high. HELP!! Props to those that have this one figured out.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
I searched the threads but couldn't find what I was looking for so hoping to find some help here. About two years ago I installed a Hard Krome sidewinder exhaust and finally decided to get a used power commander 3 and do the modified version of Caddman kit mod which is adding air cleaner to right side with left side stock. I completely removed the ISC valves and capped off the tubes. My meanie looks to be a California model because it has an EVAP cannister in left side cover. First time out with the new mods was unbelievable...ran like a raped ape with a power band that wasn't there before. I was grinning from ear to ear, until the next day when I had more time to put it through the paces. It developed a strange misfire like one or two of the spark plug wires came off but it would do that intermittently. It would run fine one second and then the other run like crap. Checked plugs, front two were black from the misfire. I decided to unplug the PC3 completely and the problem went away. However, I developed a new problem...throttle sticking. Funny thing is, it doesn't seem to be mechanical because the twist throttle will return, along with the cables and of course the butterflies of the valve body, yet the rpm's stay way high. HELP!! Props to those that have this one figured out.
Would it be a problem with the ECM or perhaps fuel pressure regulator?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Looks like I stumped everyone with this one including myself. Well I found out why the throttle was intermittently sticking...the connector for the lead that goes to the TPS fell down, when I disconnected it, in such a way as to get perfectly jammed into the throttle linkage. Even though the butterfly would close it was holding something open on the throttle. As far as the first problem, I believe it was a bad t-tap connection on the TPS. I guess it just sometimes better to figure things out yourself, lol.
 
1 - 3 of 3 Posts
Top