RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
719 Posts
Discussion Starter #1
My z1000 is brand new. I also have a 2003 Honda 919, for sale, and a 2007 ZX-14. Since I am selling the 919 I decided to return it to as close to stock as possible and sell the extra bits on the side to try and make back some $. Anyway, I removed the speedohealer v4 from it and was about to offer it for sale when I realized I would just have to buy another for the z1000 at some point and it got me to thinkin. First, does the v4 SH work on the z1000 and can I get the proper harness separately. If you look at the Healtech website they spec the V4 SH with the universal harness. OK, good.. it works with the SH but seriously, did Kawasaki really use a different speed sensor plug? Answer, no! I stole the K01 SH harness off my ZX-14 and plugged it right into the 2011 z1000 speed sensor/harness. I other words, if you are planning to install a :mouthwateHealTech Speedohealer V4 on your 2011 z1000 (presumably 2010 or 2011 n1k as well), save yourself some splicing into the harness and just get the kit for Kawasaki's, SHV4 + K01. Also, you can order replacement harnesses from a HealTech distributor. Check the Healtech site to find a distributor.

This pleased me since I did not relish the thought of cutting into the speed sensor harness... and I did not. :~

FYI.
 

·
Registered
Joined
·
1,397 Posts
I had a speedo healer on my 2006 triumph sprint after i dropped one tooth in the front and went up 1 in the back.
I wanted it to be more hooligan.

So what gearing changes are u making with your Z? I'm not planning on any changes with mine; once the exhaust is here.

have you heard of Gear commander?

This is a great tool that used for my sprint - I'm not sure if the 3rd gen z1000 is on it yet but have a look:

http://www.gearingcommander.com/
 

·
Registered
Joined
·
90 Posts
Thanks for the info, I had ordered this for my 09 ZX6R and sold the bike before installing it, and instead of selling the speedohealer I just kept it. It has the K01 harness as well.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #4
So what gearing changes are u making with your Z? I'm not planning on any changes with mine; once the exhaust is here.
Honestly, I think I like the stock gears. I might get a 16t front for longer highway trips... but for around town and in the canyons, I like it the way it is at the moment. I just want an accurate speedo and since I had the V4 already, might as well make use of it and so I got it to work for the new zed. Ordered a new K01 harness from cal-sportbike for the ZX-14. The 14 is in pieces at the moment anyway. Seems like it always is.

have you heard of Gear commander?
Very handy indeed.

Thanks for the info, I had ordered this for my 09 ZX6R and sold the bike before installing it, and instead of selling the speedohealer I just kept it. It has the K01 harness as well.
Did you install it already? If you have, were did you put it? I placed mine under the rider seat where the charcoal can used to be. ;) I ran the harness down the right side of the frame hollow where part of the main harness is, and tucked behind the main harness, then under the tank along the frame cross member and reused the plastic loop clips there which used to hold the vacuum / purge lines of the evap crap, now gone! The connector is right under the tank on the left side next to the inside edge of the frame. Straight up from the speed sensor. I didn't even have to remove the tank.. just the front screws and tipped it backwards and held it in place with a block of wood between the fuel pump ring and the air box. Easy peasy!
 

·
Registered
Joined
·
719 Posts
Discussion Starter #6
Got the zed loaded in the truck now. Heading 300 miles further south chasing warmer weather. It's actually warmed up here in last 24 hrs... it's up to 32°F. 2 days ago it was 10°F at the same time of night. Still too cold to ride plus 40% chance of snow 2day... anyway, taking GPS and I will calibrate the Speedohealer on Sunday, probably somewhere on I-15 between St. George Utah and Mesquite Nevada. 60°F & partly cloudy and only 10% chance of rain. Much better odds. I will confirm the speedohealer v4 works with the k01 harness and find the correction factor to match my bike. I read in another thread, here on riderforums, that it is about 6% fast... so I will start with that. If it's only 6% off then it will certainly not be the worst I have seen.

More to come later.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #9 (Edited)
Ok, I finally got to ride the zed again this weekend. Loaded in the truck Friday and took it to St. George UT for a bit of a ride on Saturday in some sun and temps well above freezing. With my hand held GPS and close to 200 miles of testing and adjusting, I currently have the Speedohealer set for a -7.4% correction. It's close, but still off a bit, reads too slow now but I think I am within less than 1% accuracy now. I will get it closer as the weather warms and I can get out on it more.

Anyway, so me and buddy tore a$$ thru the Virgin river pass, twice. Basically did 90+ mph thru the canyon. I was a blast. Tell ya what tho... that bike is thirsty. With the throttle cranked up like that and keeping the r's up.. lots of 3rd & 4th gear at speeds of 85 to 105... damn, was lucky if I got 25 mpg.

So back home early this morning and slept most of the day, when I get up it's almost 60°F... so I got to ride it a few miles here in Salt Lake. Today was the warmest day we have had since November 7th. I took delivery of the z on Nov 17th, it was barely 55°F that day.

Anyway, effing awesome weekend.
 

·
Registered
Joined
·
7 Posts
does anyone on here know how to install the V4 speedohealer on a 2014 kawasaki z1000 I realize I need to slice into certain wires I'm wondering what color wire does what I have a manuel but it does not go into color code details on speed sensor any help would be awesome the speedhealer came with red splice clamps instead of just putting a 4pin y splitter on the end to plug and play i guess its not as bad as cutting wires but it still sucks
 

·
Registered
Joined
·
7 Posts
Has anyone installed the healtech speedo healer on a 2014 z1000 I followed the directions and spliced into the speedo harness and connected everything as instructed and when I turned the key on not the bike to program it went through the steps and after it programed there's nothing speedo just says zero and the speedo heaker is blank i have reset it many times and nothing so disconnected the green and white wires and I reconnected the number 10 pink wire and my speedometer works again so I don't know whats going on anyone with any info please let me know thank you
 
1 - 11 of 11 Posts
Top