RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just brought a used 2006 Ninja 650r a few days ago and failed to noticed that the front brake when activated does not turn on the brake light. Is there anything I can do on my own to fix it or do I need professional help for this? Basically, is it an easy fix or will it cost money?
 

·
Registered
Joined
·
1,251 Posts
Its hard to say. You need to start at the lever and first make sure that wire going to the switch is connected. The metal tabs on this switch can bend easily so unplug the connector and make sure both tabs are there and not broken. Check the tail light fuse. Do you need the repair manual? There is a free download available. It's not going to be a ton of help for this, I was looking through it quickly and each section just kept referring me to another section for more information. Rather frustrating.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for your advice. I checked the wiring going to the switch under the lever, one of the connectors was disconnected and filled with dirt, I cleaned it out and plugged it back in. Its all good and working now.
 
  • Like
Reactions: Smash

·
Registered
Joined
·
997 Posts
Thanks for your advice. I checked the wiring going to the switch under the lever, one of the connectors was disconnected and filled with dirt, I cleaned it out and plugged it back in. Its all good and working now.
99% of the time that's the problem - bad connection.
 
1 - 4 of 4 Posts
Top