RiderForums.com - Kawasaki Motorcycle Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Hey Riders,
So I have a '15 Ninja and is pretty low on miles still....maybe 2k? I have done a few oil changes and weekly clean the chain. I try to check my tire pressure after 200 miles of riding each time. I never had an issue with the bike all summer but yesterday my engine light came on for about 2 mins, then turned off and stayed off for the duration of my commute home (30 mins).

I have installed sport bars from 650ninja, and an intergrated tail light for mods (not sure if this would effect the ecu at all but worth mentioning)

The bike does not sound any different, and I am not noticing any difference in performance. But the light is bugging me, is this something I can fix or do i really need to take it in?

Thanks for all your help!
 

·
Banned
Joined
·
2,525 Posts
You should be able to retrieve the code. Look in your manual, usually something like holding down a button or control for a few seconds and it should blink x times (or something...manual will state) to indicate stored codes.
 

·
Registered
Joined
·
768 Posts
Turn the ignition switch to ON.

On the display-
Press the upper button on left to display the odometer
Press the upper button on left for more than 2 seconds.

The service code(s) is displayed on the LCD by the number of two digits.
When there are a number of problems, all the service codes can be stored and the display will begin starting from the lowest number service code in the numerical order.

Then after completing all codes, the display is repeated until the ignition switch is turned to OFF or the upper button is pressed for more than 2 seconds.

For example, if three problems occurred in the order of 56, 14, 31, the service codes are displayed (each two seconds) from the lowest number in the order listed as shown below. (14 → 31 → 56)→(14 → 31→ 56) →· · ·(repeated)

if there is no problem or when the repair has been done, the yellow engine warning indicator light (LED) goes off and service code is not displayed.

Turn the ignition switch to OFF.


Self-Diagnosis
Service Code Table
Service Code Problems
11 Main throttle sensor malfunction, wiring open or short
12 Intake air pressure sensor malfunction, wiring open or short
13 Intake air temperature sensor malfunction, wiring open or short
14 Water temperature sensor malfunction, wiring open or short
21 Crankshaft sensor malfunction, wiring open or short
24 Speed sensor malfunction, wiring open or short
31 Vehicle-down sensor malfunction, wiring open or short
32 Subthrottle sensor malfunction, wiring open or short
33 Oxygen sensor inactivation, wiring open or short (Equipped models)
39 ECU communication error
51 Stick (Ignition) coil #1 malfunction, wiring open or short
52 Stick (Ignition) coil #2 malfunction, wiring open or short
56 Radiator fan relay malfunction, wiring open or short
62 Subthrottle valve actuator malfunction, wiring open or short
64 Air switching valve malfunction, wiring open or short
67 Oxygen sensor heater malfunction, wiring open or short (Equipped models)
94 Oxygen sensor malfunction, wiring open or short (Equipped models)
3A Purge valve malfunction, wiring open or short (CAL, SEA-B1 and TH models)
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #4 ·
Thanks both of you for the quick responce.

So I did everything @jeepincbum said...got the odom to show, then held the upper button for a few seconds, but nothing. No numbers, no engine light on....only lights that were on in the "dash" were brights and oil, which i believe is normal (i ride with brights on in day and the oil has always been on until engine kicks over since i had bike).

So does this mean as far as the ECU cares, there is no problem with the bike?


Also....I think its time to do a real good overlook on my bike, I am the first owner, and it has 4k miles on it now. I know chain last from 10-20k, and the OEM tires are roughly 6k depending on riding behavior. I have done a few oil changes and nothing as far as debris or metal shavings were in the oil in the first two so now I am doing every 4k. I check the air filter every few weeks and still looks good...and I couldnt really find where in the manual it says to change it (using magnum1.com service manual) but I would guess it is up to the rider? whenever it looks bad?

anything else would be a great help, trying to break the habit of running to the stealership every time i think i need something done :)
 

·
Registered
Joined
·
1 Posts
Hey Riders,
So I have a '15 Ninja and is pretty low on miles still....maybe 2k? I have done a few oil changes and weekly clean the chain. I try to check my tire pressure after 200 miles of riding each time. I never had an issue with the bike all summer but yesterday my engine light came on for about 2 mins, then turned off and stayed off for the duration of my commute home (30 mins).

I have installed sport bars from 650ninja, and an intergrated tail light for mods (not sure if this would effect the ecu at all but worth mentioning)

The bike does not sound any different, and I am not noticing any difference in performance. But the light is bugging me, is this something I can fix or do i really need to take it in?

Thanks for all your help!
Hi, I would like to follow up with your issue.My bike does the same when first start in the morning.Check engine light goes on for about 2mins then turn off (longer than usual).After that will not goes on for the rest of the day... Do you know what happened to your bike?
 

·
Administrator
Joined
·
2,766 Posts
Hi, I would like to follow up with your issue.My bike does the same when first start in the morning.Check engine light goes on for about 2mins then turn off (longer than usual).After that will not goes on for the rest of the day... Do you know what happened to your bike?
This is a very old thread, and that member hasn't been here for four years, so it's unlikely that you will get a reply. Read through the responses above for some advice and maybe consult a workshop manual. You could also try starting a new thread and see if you get any responses.
 
1 - 7 of 7 Posts
Top