RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 · (Edited)
Greetings!
Once again I'm in a need of advice. My 2009 Ninja is having troubles starting. It needs couple of cranks before the engine starts.
Last season I thought it may be a weak battery, because it was at least 10 years old. Now the bike is equipped with a brand new Battery.
The connections at the terminals are tight and still it takes more than usual cranking to start the engine.
Any suggestions as what should I check?
Thanks
 

·
Registered
Joined
·
414 Posts
Did it start doing it suddenly or did it gradually get worse?
If it started suddenly did you service or modify anything on the bike recently?
Poor fuel pressure, spark plug fouling, poor fuel metering caused by sensor faults, ignition issues can be caused by earthing and wiring an earthing issues, could be coils, clogged fuel filter, pump....
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #4 ·
it started gradually. last season it started having difficulty starting. I thought it was the battery because it was the original one - 10 years old. So i replace it, but the problem persisted. No mods except the new battery.
I'll pull it apart the coming weekend to check electrical connections, and spark plugs. Bike have about 30 000 km on it.
 

·
Super Moderator
Joined
·
2,578 Posts
it started gradually. last season it started having difficulty starting. I thought it was the battery because it was the original one - 10 years old. So i replace it, but the problem persisted. No mods except the new battery.
I'll pull it apart the coming weekend to check electrical connections, and spark plugs. Bike have about 30 000 km on it.
30,000 on original plugs? Replace them with Iridium and check/replace air filter.
 
1 - 5 of 5 Posts
Top