RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 4 of 4 Posts

·
The Deer Slayer
Joined
·
7,382 Posts
Discussion Starter #1
Do you guys use those cable lubricators, the ones that attach to cable with a screw on piece, and attachment for can of lube ? I've seen them, but was never sure exactly how to use them. Do you compleatly un-hook cable ? The throttle cable could use a go, but it is such a chore un hooking the whole thing.

There are adjusters mid way through cable run for both throttle cables. Can I lube it there ? With all the monkeying I've done, the throttle has lost it's snap back it once had. Cruise control anybody ? :rolleyes:

What about clutch cable ?

Tony
 

·
West Coast Moderator
Joined
·
12,996 Posts
Some guys swear by 'em, I just swear at 'em. I usually end up disconnecting the cable and letting the lube run down through the cover. I've yet to find a good cable lube, also. I usually end up using something like LPS or "Marvel Mystery Oil". Mystery oil is kinda expensive, but it has worked the best so far for me.
 

·
Registered
Joined
·
965 Posts
I use the cable oiler you described for all cables and I'm happy with it. My choice is WD40 for cables that are really stuck. Otherwise plain motor oil is OK but you don't get it in a spray can!
You should remove the upper cable end (either gas or clutch) and squirt WD40 until you can see it coming from the bottom opening.
If you lube it at the mid way adjusters, you re only lubing the cable from there downwards.

Aris
 
1 - 4 of 4 Posts
Top