RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter #1
My issue is with a 1980 kz750 h1 - electric ignition not those screwy points and the exhaust is a 4-1 (kerker or bassani) and the original baffle went mia. the problem is with the floats even the mount screw base of the float bowl and 135 secondary main jets as opposed to 125 from the factory, a k&n filter and a fairly restrictive baffle about 1.5 inches inside with a 2.5" pipe overall the engine still runs hot/lean. do I need to go to 1 inch baffle?
 

·
Registered
Joined
·
2,280 Posts
it seems pretty dark white inside the exhaust. where could I find a well fitting baffle for a pipe inside diameter of just under 2.5".
No idea on the baffle, but have you thought about fitting a stock zr-7 exhaust can on your bike?
They can be had for pretty cheap. Might help ...
 

·
Registered
Joined
·
231 Posts
Discussion Starter #6
I am a little confused about the jet kit. I have the jet kit for the pod filters but they kept getting wet so I put the airbox and k&n filter with the stage three jets still on there. I went 385 miles along the outside of the puget sound since last friday and I wonder about atmospheric altitude pressure.
 

·
Registered
Joined
·
231 Posts
Discussion Starter #7 (Edited)
yeah, a hundred miles a day but I got stung by a bee so I decided to call it quits.
so maybe it isn't the exhaust is what I am seeing but instead the altitude. here are the spark plugs. get-attachment (11).jpg
 
1 - 7 of 7 Posts
Top