RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Hello so I got a 01 ZR7S about a month ago. When I first got it, I noticed when I would run full throttle and quickly shift into the next gear then run full throttle again, the rpms would stay really high as if I never shifted. (I assumed I wasn’t going to the next gear because it was difficult to shift (common problem apparently and I easily fixed it) so I know for sure that’s not the issue.) But for the past week or so, I noticed if I full throttle in first gear the rear tire will kind of jolt, then I’ll let off the throttle, go into second gear smoothly, let it fully engage, then full throttle again, and the rear tire will jolt and not just once, it’ll jolt two or three times, but this only started recently. The high rpms is still happening. In third gear today I was accelerating kind of fast and the rpms would climb normally but then shoot up real high mid-way through, if I let off the throttle and run again then it’s fine. I don’t know too much about bikes, but is my clutch slipping?? Is the clutch just progressively getting worse?? Someone told me my transmission may not be fully engaging but I don’t really trust their word. Also I noticed when I’m in neutral, and the clutch lever is pulled all the way in, if I rev the bike at all and try to drop down into first without letting the rpms fall back down, I hear a rattling from my shifter and it won’t let me go into first gear. I have to wait until my rpms fall all the way to idle. Could it be that my clutch isn’t fully disengaging?? Maybe tightening the clutch cable will fix that problem? Please help! Thank you!!
 
1 - 1 of 1 Posts
Top