RiderForums.com - Kawasaki Motorcycle Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2020 concours with 9500 miles . I was just into 2nd gear while leaving a traffic light under perfect weather conditions in Florida and my councours began to bog down . The brakes were engaging without any action on my part . I came to a stop in the middle of the lane and my friend on a 13 year old concours who was following me hit my left bag and went down in the median . My friend and his bike were fine. The truck behind him stopped and we horsed my bike onto the median . My brakes remained fully engaged for 2 minutes or so and then finally relaxed . I rode around the nearby parking lot and then rode it 5 minutes home. It seems that for some reason the master cylinder fully engaged . If that had happened at a higher speed I might be dead . Im going to Trailer it to my closest dealer. Anybody else ever experience this or have a better idea what happened ?
 

·
Registered
Joined
·
8,732 Posts
Do you have the stock brake lever on the bike? I have heard of an occasional issue with the abs pump, but not many.

Kawasaki has usually fixed research bad pumps under warranty. Even if the bike was no longer covered.

You should find a new riding friend. There is no excuse that is good enough for running into you.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Do you have the stock brake lever on the bike? I have heard of an occasional issue with the abs pump, but not many.

Kawasaki has usually fixed research bad pumps under warranty. Even if the bike was no longer covered.

You should find a new riding friend. There is no excuse that is good enough for running into you.
Do you have the stock brake lever on the bike? I have heard of an occasional issue with the abs pump, but not many.

Kawasaki has usually fixed research bad pumps under warranty. Even if the bike was no longer covered.

You should find a new riding friend. There is no excuse that is good enough for running into you.
Thanks for the response .I do have a stock lever. I will ask the dealer about the abs pump . It was a tough situation ...I think I will hang onto the friend .
 

·
Registered
Joined
·
8,732 Posts
What happens next time when you need to stop quickly? Does he knock you in front of the dump truck? I'd be more concerned about this than the brake lock up. That's fixable.. He was following too close.

When someone doesn't have that basic understanding, that is scary. Hopefully this is what it took for him to learn. Don't let them off by offering an excuse.

Always follow the rider you can't trust, if you are forced to ride with them.

Is your bike 100% stock? No peg lowering kit? I asked boitthe lever, but the pedal can do the same thing if it doesn't have enough play. The fluid can heat up, locking the system. When it cools down, the pressure releases.

In theory, you could do this if the master cylinder reservoir , front or rear, is too full, but you would see this.

The way yours cooled down and released makes me suspect this more so than a bad pump. Those typically stay locked.
 

·
Zero Tolerance
Joined
·
2,779 Posts
I would probably consider emptying the brake reservoir and flushing the front brake lines. If there is some crud in the reservoir then it could be blocking the fine needle hole in the bottom of the reservoir, meaning that the pressure is maintained to the brake pads. Letting the bike sit for a while allows the brake fluid to push the crud back into the reservoir - and on it goes.

I'm kind of on RC's side about your mate. No-one should be following that closely, especially since you said the brakes started to bog down, which implies not an emergency stop.

But hey - maybe you both learnt something.

Keep us posted on the cause of the issue - it might help other members who experience the same problem.
 

·
Registered
Joined
·
8,732 Posts
OZ, your flushing comment. I like the idea. I My c14 is old,but I've flushed its brakes several times. Twice, per year, since 2010.

I bought it used, in late 2010. It only had 1700 miles on it and it was in perfect condition. Stock, except for a slip on exhaust .
The first time I flushed the brakes, they looked like they were full of pepper. The fluid looked ok . It wasn't discolored, but those chunks were visible. Once I flushed, they never came back. I say "they" because it looked like pepper chunks, or flakes. Perfect size to plug a small orfice.
 
  • Like
Reactions: Ozninjaguy

·
Registered
Joined
·
8,732 Posts
Please let us know how how this turns out....hopefully, it doesn't cost you anything.
 
1 - 7 of 7 Posts
Top