RiderForums.com - Kawasaki Motorcycle Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I bought this ZRX a few months ago running on three, I thought clean the carbs and it will be job done..... cleaning completed started the bike : sweet, running on four nicely at idle, I had not put the air box back on because I intended to put individual K&N’s on it, so... I gave her some gas and nice response up to 4.500 then nothing, give it full beans and it pulses up and down but will not rev up higher than say 5000rpm then back to nothing and back to 5, OK, I put the K&N’s on still the same, I put 98 main jets in the middle two carbs and 95’s in the two outside, the adjustable fuel screws are set at 2.5 turns out, still the same. What am I missing here, could it be electronic problems?
Help.....
 

·
Super Moderator
Joined
·
2,578 Posts
I bought this ZRX a few months ago running on three, I thought clean the carbs and it will be job done..... cleaning completed started the bike : sweet, running on four nicely at idle, I had not put the air box back on because I intended to put individual K&N’s on it, so... I gave her some gas and nice response up to 4.500 then nothing, give it full beans and it pulses up and down but will not rev up higher than say 5000rpm then back to nothing and back to 5, OK, I put the K&N’s on still the same, I put 98 main jets in the middle two carbs and 95’s in the two outside, the adjustable fuel screws are set at 2.5 turns out, still the same. What am I missing here, could it be electronic problems?
Help.....
Hi. Welcome onboard. I don't know about the ZRX, but I do know that some bikes will not run with pod filters. They need the airbox to run effectively. I found that out years ago when I tried putting K&N pod filters on my GSX650. It ran exactly as you state, but once the original airbox was back on - ran perfectly. Give it a try.
 
1 - 2 of 2 Posts
Top