RiderForums.com - Kawasaki Motorcycle Forum banner

turn signals

  1. Anyone know where to get good LED signal aftermarket mirrors?

    Ninja 650R Accessories
    I found a bunch on Amazon and ebay and such that look amazing, but they're like $30 and stink of low-quality to me. Does anyone have experience with any aftermarket LED mirrors they'd recommend? I think it would seriously compliment the look of my bike big time. But I don't want some cheap...
  2. LED Turn Signals - Integrated Brake/Running Lights

    Z1K/Z750 Accessories
    Long time lurker around here. I've got an 06/07 Z750S I was lucky enough to pick up last spring from the dealership with 90km on it, amazing noone picked it up. All in black, love it to death, ride it all through the winter. (Which on Vancouver Island, winter isn't as terrible as the rest of...
  3. Tail light and turn signals not on when running... Any tips?

    Mean Streak Maintenance
    My front turn signals stay lit like marker lamps when the bike is running, but the rear ones and tail light are dark. Brake lights come on when activated as do the turn signals, but they're otherwise dark when running... Can any of you perhaps point me in the right direction? I haven't yet...
  4. Remove front turn signals??

    3rd Gen Z1000/Z1000SX/Ninja 1000
    Was wondering if anyone has an idea on how to remove the front turn signals on a 11 N1K. I want to take them off and smoke them, but I can't figure out how to get them off! Any input would help!! Thanks Guys!
  5. Turn signals too hard to see on Bandit 1200

    General Bandit Chat
    I bought a 2003 Bandit S this year and after I almost got run over turning left, I checked and discovered that in the daytime the front turn signals are so recessed, and dim, that a person can't really see them blinking off and on (!). I'm going to look into the possibility getting brighter...
  6. Rear turn signal question

    Mean Streak Accessories
    Hi guys I gotta quite a stumper here. I just installed a set of MBW rear turns on my meanie. The problem is that it doesn't seem to be working as running lights. They work perfectly fine as turns but not as a running light I have hooked up a load equalizer from custom dynamics. I have just...
Top