Charging system issue?

Logo

Charging system issue?

This is a discussion on Charging system issue? within the Ninja 650R Maintenance forums, part of the Kawasaki Ninja 650R category; Battery light came on/off while riding. Checked voltage and found battery to be undercharged. After recharge it still happened again and since I don't know ...

Results 1 to 4 of 4
  1. #1
    Newbie OLDZ1KAW's Avatar
    Join Date
    Nov 2018
    Location
    Rancho Cucamonga, CA
    Posts
    21

    Question Charging system issue?

    Battery light came on/off while riding. Checked voltage and found battery to be undercharged. After recharge it still happened again and since I don't know the exact age of the battery I just replaced it with a new one.

    Now when measuring charging voltage while running I'm getting 13.5v, however every couple seconds the voltage dips a few volts and I notice the headlight slightly dimming/pulsing. I'm wondering if the regulator/rectifier or stator might be going out? Usually charging voltage should be steady and closer to 14v.

    Unfortunately the R/R is tucked up on top of the radiator so access for testing doesn't look easy. Anyone have any tips? Maybe I'll just jump to stator testing since I can see that connector easily?

    I appreciate any help...I'm mostly thrown off by the fluctuating voltage and headlight...something doesn't seem quite right? Thanks!
    2012 Ninja 650 Black, fender eliminator, D3 grips

  2. #2
    Newbie OLDZ1KAW's Avatar
    Join Date
    Nov 2018
    Location
    Rancho Cucamonga, CA
    Posts
    21
    Ok I just tested all 3 legs of the stator and reading ~35v between 2 of them and on the 3rd I'm reading ~3v (measured with bike running at 5000 rpm). So it looks like the stator is bad. I'm relieved actually since the R/R looks to be way more of a pain to replace.
    2012 Ninja 650 Black, fender eliminator, D3 grips

  3. #3
    Up-And Comer Buddhaman's Avatar
    Join Date
    Aug 2015
    Location
    Norman, OK
    Age
    31
    Posts
    85
    Thanked
    6 times
    I ended up checking the entire charging system when I was having issues. Thankfully the ‘07 has the r/r just below the battery. I had a bad stator too, easy to replace thankfully. I’d recommend draining the oil first (may as well change it afterwards) before taking the cover off. I reused my gasket but a new one isn’t too pricey if you want the security of a fresh seal.

  4. Remove Advertisements
    RiderForums.com
    Advertisements
     

  5. #4
    Newbie OLDZ1KAW's Avatar
    Join Date
    Nov 2018
    Location
    Rancho Cucamonga, CA
    Posts
    21
    Thanks for the tips! I ordered a new stator from RMStator today.
    2012 Ninja 650 Black, fender eliminator, D3 grips

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Charging system went south
    By speedracer in forum General Mean Streak
    Replies: 6
    Last Post: 08-15-15, 09:12 AM
  2. Charging System Output-Adding assories
    By Magnusvela in forum General Mean Streak
    Replies: 1
    Last Post: 01-31-14, 04:52 PM
  3. Charging system issues
    By Gryph in forum Ninja 650R Maintenance
    Replies: 4
    Last Post: 06-09-13, 08:33 AM
  4. charging system
    By reddenjeff in forum Z1K/Z750 Maintenance
    Replies: 7
    Last Post: 03-12-04, 02:39 PM
  5. Battery or charging problem?
    By kim zr7f2 in forum ZR-7 Maintenance
    Replies: 20
    Last Post: 09-14-03, 01:25 PM

Search tags for this page

ninja 650 stator issue

Click on a term to search for related topics.