Mean Streak Power surging around 2000 rpm

Logo

Mean Streak Power surging around 2000 rpm

This is a discussion on Mean Streak Power surging around 2000 rpm within the Mean Streak Maintenance forums, part of the Kawasaki Mean Streak category; Anybody know what may be causing this varing rpm surge ? Just noticed it lately. Most noticable around 2000 rpm and in 1st gear....

Page 1 of 2 12 LastLast
Results 1 to 15 of 27
  1. #1
    Up-And Comer Oldmotorcyclefa's Avatar
    Join Date
    Aug 2006
    Location
    Monroe,Louisiana
    Age
    77
    Posts
    31
    Thanked
    1 times

    Mean Streak Power surging around 2000 rpm

    Anybody know what may be causing this varing rpm surge ? Just noticed it lately. Most noticable around 2000 rpm and in 1st gear.

  2. #2
    Site Elder zootech's Avatar
    Join Date
    Jun 2005
    Location
    Columbus, OH
    Age
    42
    Posts
    972
    Thanked
    1 times
    Either the engine is running lean on the idle circuit, or your fuel system is failing (clogged vent tube in the gas cap or a failing fuel pump).

    Have you done any engine mods?
    ~Bikeless~

  3. #3
    Up-And Comer bonefish's Avatar
    Join Date
    Jul 2006
    Location
    whiteweird, SD
    Age
    50
    Posts
    39
    man, i just noticed that particular problem w/ my meanie. only upgrade i got is BUB chambermaids, and it only happens when it's hot. think that's a lean issue? been looking for a good excuse to buy a PC or something similar, and if yer gonna do that might as well put a new intake on, right?
    '03 purple mean streak, custom graphics, mapam forward controls, mapam backrest, bub staggered chambermaids.

  4. Remove Advertisements
    RiderForums.com
    Advertisements
     

  5. #4
    Supreme Being Streaker's Avatar
    Join Date
    Apr 2006
    Posts
    2,139
    Thanked
    12 times
    Sounds like a good enough excuse to me. That coupled with the fact that it's a shaft drive bike makes it even that much more noticeable.
    2006 Mean Streak

    http://www.meancycles.com/owners2/ho...0&OwnerID=1837

    List of Mods
    Vance & Hines Bigshots Exhaust, Thunder Mfg. Tornado Intake, Kuryakyn Wild Things TFI, 12" Smooth Ride Custom Chrome Shocks, Danny Gray Flame Seat, Reaper Front Fender, Radiator Chin Scoop, Front Axle Spikes, Rear Fender Spikes, Iso Grips with Spike ends, Kewl Metal Risers, Led Rear Turn Signals, Smoke Tail and Turn Signal Covers, Stebel Air Horn, Kuryakyn Retro Pegs, Arlen Ness Mirrors, Custom Jack Daniels Gauge Faces, Jack Daniels Air Cleaner Cover, Sidemount License Mount with LED, HotBox, Custom Mounted Softail Deluxe Hardbags

  6. #5
    Up-And Comer Oldmotorcyclefa's Avatar
    Join Date
    Aug 2006
    Location
    Monroe,Louisiana
    Age
    77
    Posts
    31
    Thanked
    1 times

    Question Power Surging around 1500/2000 RPM any Gear

    This surging thing is driving me nuts! Local shop says if no diagnosic code he don't know. Guess I will rig a tee up to check fuel pressure. Not experienced enough yet with the Fuel Injection System. I rode a Vulcan Classic this weekend and it did't have that problem. Somebody with Kawasaki has got to know something about this. Once above 2000 not noticable, seems only at 1500/2000. Feels like it is starving out of gas and then comming back. I have run a can of sea foam thru it and now running some Yamaha cleaner recommended by kawasaki dealer through it. I don't think the magic tonic is going to fix this one! Know any good books on Motorcycle Fuel Injection?

  7. #6
    Rising Star crazyirv's Avatar
    Join Date
    Jul 2005
    Location
    Pleasant Hill, California
    Posts
    341
    Quote Originally Posted by Oldmotorcyclefa
    Anybody know what may be causing this varing rpm surge ? Just noticed it lately. Most noticable around 2000 rpm and in 1st gear.

    Try the Delphi Vulcan Forum:


    http://forums.delphiforums.com/kawvulcan/start

  8. #7
    Site Elder Dave_Pa's Avatar
    Join Date
    Aug 2006
    Location
    Dunmore, Pa.
    Age
    58
    Posts
    698
    I would change the filter and drain the tank. May have picked up some moisture.
    Kuryakyn Iso Flame Grips w/Throtle Rockers
    Custom Black Mortans Skirt Blower Exaust
    Rakaposki Lava Red Leather Saddlebags
    Chrome Rear Peg Eliminators
    Fire and Steel Wind Screen
    AfterMarket Fender Struts
    Chrome Coasters installed
    Thunder Tornado Intake
    Cut Stock Custom Seat
    Memphis Shade Lowers
    Scorpion Alarm System
    Reflectors Removed
    VN 750 Foot Pegs
    Mirror Extentions
    Engin Ice
    PCIII


    When you turn your bike on, Dos' it return the favor?
    Screammin Meanni.......

  9. #8
    Newbie rdog130's Avatar
    Join Date
    May 2011
    Posts
    1

    I had same preoblem

    I had the same problem. truns out o was low on oil. changed oil no problem sense

  10. #9
    Newbie JOSHUADICKEY's Avatar
    Join Date
    May 2008
    Posts
    13
    I had the same problem too! Surging at 1500/2000rpm... My issue began after i had the tank powder coated. There was some overspray in the tank and I was too anxious to ride to bother cleaning it out... within a week i started noticing the symptoms. I also tried fuel injector cleaner to no avail.



    The problem obviously is fuel delivery related, and seems to be a lean condition so as a quick fix before a ride the other day I added a resister inline to the temp sensor to richen up the mixture, however, this only slightly improved things. It is definitely better now, but still not perfect. Did the original poster ever solve his problem? Please post if so! I think my next step is what i should have done in the first place... take off that tank and clean clean clean and possible put in a new fuel pump (it looks like the filter is integral to the pump, but fortunately the pump can be purchased at advanced auto for less than $150 (it's the same pump as the one on the '89 Mitsubishi Galant).

    I will post back when i've got the new pump installed... keeping fingers crossed.

  11. #10
    Rising Star oneworden's Avatar
    Join Date
    Sep 2010
    Location
    Franklin, WI
    Age
    36
    Posts
    376
    Thanked
    28 times
    I notice mind has a very twitchy throttle responce around the 2k mark. If I am off the throttle rolling up to a light in second gear then try to get back on the throttle without using the clutch the thing starts bucking like an idiot.
    02' Meanie - Gold (sounds pricier)
    - F&S strut covers and bag stay
    - V&H Long Shots w/o baffles
    - Caddman single side
    - Coaster'ed
    - TFI

  12. #11
    Rising Star jwarden's Avatar
    Join Date
    May 2011
    Location
    at home
    Posts
    269
    Quote Originally Posted by oneworden View Post
    I notice mind has a very twitchy throttle responce around the 2k mark. If I am off the throttle rolling up to a light in second gear then try to get back on the throttle without using the clutch the thing starts bucking like an idiot.
    Sounds like a PCIII map issue. Lean most likely. Try running along at 2,000 rpm ~45 mph in 5th gear. Is it smooth or staggery?

    What map are you running?
    Last edited by jwarden; 08-03-11 at 10:11 PM.

  13. #12
    Rising Star va3ux's Avatar
    Join Date
    Oct 2010
    Location
    Niagara Region - Southern Ontario, Canada
    Posts
    474
    Thanked
    56 times
    Mine does this too. All stock except for the V&H Longshots pipes. No fuel controller or any other changes (yet).
    Phil - Southern Ontario, Canada

    2003 Mean Streak
    Muzzy 2 into 1
    Chuckster Air Intake
    PC III
    63,000 km

  14. #13
    Newbie JOSHUADICKEY's Avatar
    Join Date
    May 2008
    Posts
    13
    Ok, so I worked on the fuel system today...

    First I took off the tank and tried to clean it. there was some slight sediment, but nothing much to speak of so i moved on to the fuel pump assembly. I disassembled it, cleaned the fuel strainer with a dip in some carb cleaner, and replaced the fuel filter with a generic one from advanced auto. I put the bike back together and took it for a test drive... still surging/stumbling at around 2000rpm. I then changed the coolant and gear oil just for fun and went back to advance auto to buy a new fuel pump. For anyone else interested the pump itself is a mitsubishi uc-t30... it is a common pump, used in a lot of other bikes and cars including the '99 mazda miata. I got an aftermarket pump from advance auto (airtex brand, p/n E2111). After I got it all done and put back together... same problem! Plus, i don't think the new pump sounds as good as the old one!

    Back to the drawing board...

  15. #14
    Newbie JOSHUADICKEY's Avatar
    Join Date
    May 2008
    Posts
    13
    Ran some seafoam through the intake... seems to have made a little bit of a difference. I'll try another can after work. My latest thoughts...

    The stock air filter was left unchanged and eventually fell apart. some foam crap got sucked into the throttle body. I'm not sure if it made its way all the way into the combustion chamber but it seems likely and this may have caused some crap to build up inside the cylinders. Not a good situation. I'm not sure why this would affect me at 1500/2000rpm though??

    Has anyone else resolved this issue? My bike runs alright. especially under throttle or high rpms it really runs great. but it is annoying to have this surging at 1500/2000rpm especially since 2000 is where i used to like to cruise. One more note... the surging seems to only occur when 'cruising' at 2000rpms --> when under heavy acceleration/throttle, the 1500/2000rpm range is fine, but at a steady state or deceleration, it starts to buck.


    If anyone has any experience please chip in!

  16. #15
    Newbie JOSHUADICKEY's Avatar
    Join Date
    May 2008
    Posts
    13
    just found this article...
    http://www.gadgetjq.com/tb_cleaning.htm

    can't wait to get home and try it out!

Page 1 of 2 12 LastLast

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

02 kawasaki vulcan 1500 idle surge

,
2003 kawasaki vulcan 1500 bucking during acceleration
,

2003 mean streak surging

,
kawasaki mean streak idle funny
,
kawasaki mean streak surge on acceleration
,

kawasaki mean streak surging

,
kawasaki mean streak vacuum leak
,
kawasaki mean strek surges at steady throttle
,
vn1500 surge at idle
,
vulcan 1500 engine surging
Click on a term to search for related topics.