Clutch lever won't pull in. Please help!

Logo

    
    

Clutch lever won't pull in. Please help!

This is a discussion on Clutch lever won't pull in. Please help! within the Mean Streak Maintenance forums, part of the Kawasaki Mean Streak category; I have a 2007 Kawasaki Vulcan Meanstreak SE. I just did a complete engine swap everything went well and it started up fine. I just ...

Results 1 to 3 of 3
  1. #1
    Newbie KayEeyeAre's Avatar
    Join Date
    Mar 2017
    Posts
    1

    Clutch lever won't pull in. Please help!

    I have a 2007 Kawasaki Vulcan Meanstreak SE. I just did a complete engine swap everything went well and it started up fine. I just need to do some fine tuning on the idle since it's a new engine. the new engine didn't have the clutch slave cylinder so I put my old one on the new motor. I changed break fluid for the brakes and it went fine. I changed the clutch fluid which is the brake fluid dot 4 and the clutch lever won't pull in at all. It's rock hard. Any idea on what happened or what's wrong?

  2. #2
    Rising Star carmtz's Avatar
    Join Date
    Mar 2011
    Location
    Weslaco , Texas
    Age
    59
    Posts
    159
    Thanked
    42 times
    Did you try bleeding it just to make sure thats not the problem

  3. #3
    Rising Star andyismarine's Avatar
    Join Date
    Dec 2014
    Location
    West Tennessee
    Posts
    151
    Thanked
    32 times
    I wonder if there is a way to get that slave cylinder slightly in a bind or misaligned?
    Id try to crack the lines loose starting at the slave cylinder with the bleed screw and see if while any of them are cracked if the handle frees up, working your way back to the lever. If you find a joint where it frees the handle up then the next thing towards the clutch should be what is holding you up.

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •