Logo

600 starting problem.

This is a discussion on 600 starting problem. within the General Bandit Chat forums, part of the Suzuki Bandit Forum category; my lad during really cold weather struggled with starting bike,when i got to it,fired up straight away,has anyone suffered with carbs icing up,fuel filter is ...

Results 1 to 2 of 2
  1. #1
    Newbie pegsy's Avatar
    Join Date
    Feb 2012
    Posts
    1

    600 starting problem.

    my lad during really cold weather struggled with starting bike,when i got to it,fired up straight away,has anyone suffered with carbs icing up,fuel filter is clean,just cleaning tank,doesnt look dirty when petrol drained.

  2. # ADS

    Welcome to the largest Kawasaki Motorcycle Forum on the web.
    Registers users do not see these ads, register today - it's free!

  3. #2
    Up-And Comer Gbenz's Avatar
    Join Date
    Jun 2011
    Location
    Washington D.C.
    Posts
    40
    I Just use sea foam with every other few tanks of gas. Make sure your battery has a lot of kick in cold weather. the air cooled bandits are cold blooded. And check your plugs

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

02 suzuki bandit 600 starting problems
,

600 bandit will not start

,
bandit 600 hard to start
,
bandit 600 starting problems
,
bondit 600 starting problems
,
electrical problems with bandit 600
,
suzuki 600 bandit starting problems
,
suzuki bandit 600 problems
,
suzuki bandit carb icing
,
suzuki bandit problem and wet weather
Click on a term to search for related topics.