2004 Kaw Concours always running cool?

Logo

    
    

2004 Kaw Concours always running cool?

This is a discussion on 2004 Kaw Concours always running cool? within the Concours 1000 forums, part of the Kawasaki Concours category; Hi. I am new to the forum. I bought a used Concours 1000cc a little while ago and it seems to always be running very ...

Results 1 to 3 of 3
  1. #1
    Newbie dav450's Avatar
    Join Date
    Mar 2015
    Location
    Homestead, Fl
    Posts
    2

    2004 Kaw Concours always running cool?

    Hi. I am new to the forum. I bought a used Concours 1000cc a little while ago and it seems to always be running very cool from temp gauge indicator (better than hot). I am in Florida (temps warm now), the fan does kick on when I turn it off. Is the low temp gauge indication normal for these models or maybe I have a problem? When I shut off the ignition, the temp needle goes down to the left, so the gauge is getting electric. Thanks for any input.
    Last edited by dav450; 03-04-15 at 06:54 PM.

  2. #2
    Supreme Being twowheeladdict's Avatar
    Join Date
    Jun 2009
    Posts
    9,874
    Thanked
    2139 times
    If you don't get much help here, you might want to check out the concours owners group. Especially Steve in Sunny Florida. He is the resident guru for the zg1000.
    Skill is what keeps you on two wheels.

    Situational awareness combined with skill is what keeps you out of harm's way.

    ATGATT combined with Situational Awareness and Skill means you might live to ride another day when that deer runs into your bike or that drunk blows through that stop sign.

  3. #3
    Newbie dav450's Avatar
    Join Date
    Mar 2015
    Location
    Homestead, Fl
    Posts
    2
    OK, thanks

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •