94 Magna electrical problems

Logo

    
    

94 Magna electrical problems

This is a discussion on 94 Magna electrical problems within the Community Feedback and Site Help forums, part of the General Forums category; Hey. So I have been having issues with my starter solenoid lots of clicking and won't start when bike is hot. It Fi ally died. ...

Results 1 to 3 of 3
  1. #1
    Newbie moses's Avatar
    Join Date
    Jun 2015
    Posts
    1

    94 Magna electrical problems

    Hey. So I have been having issues with my starter solenoid lots of clicking and won't start when bike is hot. It Fi ally died. Tues ed it over a morning after replacing battery and the whole bike went dark. Tried to bypass the solenoid with the ole screwdriver trick but still when I turn they key I get no power at all. Anyone have any ideas or suggestions. There is power I the battery as I get a spark when I touch the two leads that connect to the solenoid I get power. Thanks for any help.

  2. #2
    Supreme Being HilbillyKat's Avatar
    Join Date
    Feb 2014
    Location
    Yukon, Ok
    Posts
    2,991
    Thanked
    897 times
    Check your fuses.

  3. #3
    Supreme Being Easy Rider's Avatar
    Join Date
    Apr 2013
    Location
    N. Central Florida
    Posts
    3,123
    Thanked
    459 times
    Especially the main fuse, which usually is located in a little holder attached to the battery side of the solenoid.

    I hope you charged the new battery before using it.

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Tags for this Thread